Photometrics Prime95B demo number 2

September 13, 2017 at 2:49 pm | | hardware, review

Technical Instruments loaned me a Photometrics Prime95B back-thinned CMOS camera. I had demoed this camera before, but I was able to put it on our scope this time. Our spinning disk confocal has two camera ports, so I installed a tube lens that made the effective pixel size on the Prime95B approximately the same as our 512×512 Andor iXon EMCCD.¬†The Prime95B looked beautiful for a moderately bright sample:


(Note that I cropped the Prime95B images by approximately 60% both laterally and axially, because the illumination area on the microscope was restricted to the center of the field of view. Uncropped, the Prime95B field of view would be over twice as big in each dimension!)

At very low light imaging, I had to set the EMCCD gain very high to get an image with good signal-to-noise. The Prime95B had slightly lower sensitivity in this imaging regime, but honestly, I was surprised that its images looked that good:

The only problems I ran into had to do with the PVCAM driver for the camera having some issues in Micro-Manager (mainly with having trouble shuttering the lasers correctly), but I was able to find moderately acceptable workarounds.

If I were buying a camera for spinning disk, TIRF, epifluorescence, etc. (really, anything except single-fluorophore microscopy), I would probably get a Prime95B. I hope other sensor manufacturers and scientific camera companies follow suit and release more excellent back-thinned CMOS cameras.

1 Comment »

RSS feed for comments on this post. TrackBack URI

  1. Do you know anything about the electronics on these cameras? I’ve been using the 95B for 3 years, under low-light high sample-rate conditions, which has led me to use the camera exclusively in 12-bit (fast) mode with 2X2 binning. About a month ago, I noticed a sharp drop in signal quality. I suspected problems w my mice, my lamp,… but I’ve come to conclude that it’s the camera: an image acquired under 12 bit mode, maximizing sensitivity had a lower mean luminance value (by a factor of 4) than an image acquired under identical conditions in 16 bit mode, which is supposed to have better dynamic range but lower sensitivity.

    I suspect that there are distinct amplifier circuits mediating each acquisition mode, and that the amplifier I have been using non-stop has failed. I don’t know anything about the internal electronics of this camera, but does this sound right to you?

    thanks for any suggestions or ideas you might have on this topic.

    Nick

    Comment by Nicholas Mellen — November 12, 2019 #

Leave a comment

thanks for the comment

Powered by WordPress, Theme Based on "Pool" by Borja Fernandez
Entries and comments feeds. Valid XHTML and CSS.
^Top^